Skip navigation

Category Archives: Ubuntu

Si al intentar actualizarte a la nueva versión de Ubuntu, Oneiric Ocelot, te encuentras con el siguiente mensaje:
No se han podido encontrar las notas de publicación
Puede que el servidor esté sobrecargado.

No significa necesariamente eso 🙂
desde la instalación anterior que pude ver este síntoma en varias actualizaciones. Afortunadamente, en la mayoría de las ocasiones NO es problema de sobrecarga del servidor, sino de un problema de la interfaz 😦

Así que para actualizarte de todas maneras, utiliza el siguiente comando
sudo do-release-upgrade

En caso que no lo tengas instalado, debes instalar update-manager-core

sudo aptitude install update-manager-core

o bien

sudo apt-get install update-manager-core

Enjoy Oneiric Ocelot!!!

Anuncios

Buscando como hacer más espacio para mi ya viejo ADP1, intenté irme por los directorios que tuvieran más info y sacarlos del /data para llevarlos a alguna carpeta en la sd. Y… me estrellé con que no sabía listar los directorios ordenados por tamaño :s

Bueh, llegué a una solución que si bien no te indica el tamaño con lindo formato, al menos sirve para lo que necesito.

du -sk * | sort -n

Si usas linux y tienes una placa ethernet de intel con un chipset Intel ICH8 o ICH9 gigE, podrías ver partir a tu placa.

Los primeros reportes indican que el driver mencionado corrompe la EEPROM/NVM usada por dichos dispositivos para almacenar información tan sensible como la MAC adddress.

El fallo ya ha sido reportado como bug del kernel, en mandrivafedoraubuntu  y suse; teniendo como principales afectados a portátiles.

Si ya actualizaste el driver, es probable que aún puedas salvarte vía una actualización de BIOS, pero puede requirir reemplazo de hardware, así que tan alentadora no es la noticia. Por otro lado sí crees que IABUTIL.EXE te va a ayudar, estás equivocado. Su uso no se aconseja para nada, porque podría dejarte peor, vale decir, tu tarjeta ni siquiera aparecerá detectada.

Si usas ubuntu y ya estás corriendo Intrepid, lo mejor es que descargues el paquete module-init-tools_3.3-pre11-4ubuntu10 que pone al driver en lista negra.

sl3

Hola!

Esto es para contarles que por fin, después de un retraso que nos tenía muy nerviosos, los templates de traducción de tu distro favorita ya están disponibles para su traducción.

Así que… Happy translating!!

… y Feliz día del programador.

Actualización: Los que ya usen Intrepid en español… necesitamos feedback! algún paquete mal traducido, que aplicación no está traducida, etc. Además si tienes cuenta en Launchpad pero no eres traductor oficial, avísanos para aprobar tus traducciones.

sl3

Como sabrán, desde hace tiempo vengo participando en la traducción de mi sistema operativo favorito.

La mejor forma de contribuir a las traducciones es usando la aplicación y sugerir cadenas para su posterior inclusión en los paquetes oficiales. Esto, si no eres traductor oficial.

Aquí te cuento como mantener tus traducciones lo más actualizadas posibles.

En caso que quieras estar al día (o a la semana… o casi a la semana) lo que puedes hacer es agregar los repositorios de los packages de lenguajes. Estos están disponibles vía PPA en launchpad.

deb http://ppa.launchpad.net/ubuntu-langpack/ubuntu hardy main
deb-src http://ppa.launchpad.net/ubuntu-langpack/ubuntu hardy main

Después de agregarlos debes actualizar la información desde los repositorios y luego actualizar los paquetes correspondientes. Si no sabes como… deja un comentario 🙂

Si necesitas los packages para otra versión de ubuntu, visita la página de los langpack en launchpad. Y hablando de opciones, también hay otra página con langpacks.

hola!

he estado ausente por bastante tiempo, tanto de los web 2.0 como de otras mentas relacionadas a la red… y de las que no, también.

Esto tiene una explicación, o un par de ellas. Sucede que después de haber estado trabajando para una única empresa durante varios años, me he cambiado a otra. Ya tuve despedida, el correspondiente correo, las depedidas e incluso las bienvenidas. Así que muchos ya conocen los detalles, y los que no… pues preguntarán.

Por ahora puedo decir que estoy muy contento en mi nueva compañía y que estoy muy, pero muy ocupado tratando de entrar a _marcar goles_ como dijera un ex-colega. Así que seguiré ausente de varias cosas por un tiempo no determinado hasta ahora, aunque algunas las retomaré ASAP.

Por ahora puedo contar que ya estoy entrando a participar en el primer proyecto dentro de la compañía y según el tiempo y las políticas de ella lo permitan contaré que tal me va en mi nuevo empleo.

A todo evento, cualquier cosa que aquí diga no representa en ninguna manera el pensamiento de la compañía para la cual trabajo.

Nos vemos!!

[]

[]

sl3

La cosa se veía fácil, hasta que me encontré el primer error 🙂

Warning: require_once(Mail.php) [function.require-once]: failed to open stream: No such file or directory in F:\mediawiki\includes\UserMailer.php on line 91

Fatal error: require_once() [function.require]: Failed opening required ‘Mail.php’ (include_path=’F:\mediawiki;F:\mediawiki/includes;F:\mediawiki/languages;.;C:\php5\pear’) in F:\mediawiki\includes\UserMailer.php on line 91

chan!

veamos que encontramos en la configuración.

El error dice que falta un archivo, en este caso Mail.php . No está en mi disco, según google es un archivito de PEAR. No, no lo tengo instalado… y tampoco quiero tenerlo.

Se supone que $wgSMTP es un array con la configuración del SMTP, pero sigue sin funcionar.

En la página de settings de mediawiki  hay algo que me puede servir: un archivo de log. Lo activamos y veamos que pasa.

El mismo error y nada que me ayude en el log, considerando mis exigua experiencia con mediawiki y su debug mode.

Volviendo a UserMailer.php, me encuentro con la siguiente línea:

if (is_array( $wgSMTP )) {

Ah, que bonito.

y que pasa si $wgSMTP no es array? ah!?

mmm hurgando un poco más me encuentro con:

* This function will perform a direct (authenticated) login to
* a SMTP Server to use for mail relaying if ‘wgSMTP’ specifies an
* array of parameters. It requires PEAR:Mail to do that.
* Otherwise it just uses the standard PHP ‘mail’ function.

mmm, standard PHP ‘mail’ function…  ahí estaba lo de PEAR y… probemos con $wgSMTP = true;   sí, así, tal cual.

Con eso, al menos no necesitaremos (en teoría) el mail.php y usaremos the standard mail function de PHP … chan!  (configurada correctamente en php.ini)

mmm, nuevo mensaje de error:

No fue posible enviar el correo de confirmación. Por favor, comprueba que no haya caracteres inválidos en la dirección de correo que has ingresado. 

veamos el log…

Error sending mail: SMTP server response: 454 5.7.3 Client was not authenticated.

a ver… revisemos la configuración de php.ini. Está bien. La prueba por telnet comprueba que efectivamente no me he autenticado… diablos y cómo hago eso desde php?

googleando, no encuentro casi nada, excepto un script en php para hacer la autenticación… hummm, pero esa no es la idea… tendría que modificar la función mail de php… y con la escasa experiencia con el lenguaje… mmm. Veremos si encontramos algo más.

Siguiendo con la cosa… no encontré nada, así que a investigar y codearemos un poco en php al parecer 🙂

encontré fsockopen(), creo que me será útil.

Está conectando, ahora a mirar si podemos autenticarnos en el server.

La autenticación falla.

500 5.3.3 Unrecognized command

después de solicitar la password :S si lo hago a mano, funciona… en auto, no anda ni pa’trás.

Luego de prueba tras prueba, la solución fue enviar con fputs, cada línea de la conversación con el SMTP. A excepción  del asunto y cuerpo del mensaje.

Ahora ya está funcionando… al menos para pedir la confirmación de la cuenta de correo.

[]

[Dream Theater – Beyond this life]

sl3

Eso, a partir de las 7.10 pm nos juntamos en Elkika de Guardia Vieja en Santiago de Chile, a charlar con la excusa del nuevo release de Ubuntu.

[]

[The Rolling Stones – What you want]

sl3

Les tengo que contar algo, tenemos poleras de Ubuntu para la venta 🙂

Tienen un valor de $6.500 más gastos de envío.

Pueden ver fotos y/o el layout de las poleras  en http://www.flickr.com/groups/ubuntu-cl/

Es una edición limitada. Los interesados escriban a lecaros en ubuntu-cl punto org o a la casilla de marketing que está indicada en nuestro sitio.

La información respecto de las tallas y completación de la venta está disponible en el archivo de la lista.

No hay en stock de las poleras

(A) Polera Piqué beige manga corta de Ubuntu-cl

Que las disfruten!!!

(y manden sus action shots!!)

[]

[AC/DC – Goodbye and good riddance to bad luck]

sl3

En otra actividad de csantiba (del equipo de marketing), les contamos que ya están las poleras que mandamos a hacer para la comunidad. La entrega se hará según lo establecido en los medios de comunicación de ubuntu-cl.

Polera Negra Ubuntu
Foto de csantiba.

Están deluxe.
Esperamos pronto poder ofrecerlas a todos!!

[]
[Matchbox Twenty – Shame]
sl3

A %d blogueros les gusta esto: